aboutsummaryrefslogtreecommitdiffstats
path: root/xcftools [moved to community]
diff options
context:
space:
mode:
authorMattias Andrée <maandree@kth.se>2019-02-15 23:07:11 +0100
committerMattias Andrée <maandree@kth.se>2019-02-15 23:07:11 +0100
commit1c70adac5a9fa2984d0910cc7c8d4b2f73951327 (patch)
treed0821093bed8817748ae492299e61c8b95ac427f /xcftools [moved to community]
parent... (diff)
downloadaur-packages-1c70adac5a9fa2984d0910cc7c8d4b2f73951327.tar.gz
aur-packages-1c70adac5a9fa2984d0910cc7c8d4b2f73951327.tar.bz2
aur-packages-1c70adac5a9fa2984d0910cc7c8d4b2f73951327.tar.xz
xcftools is know in [community]
Signed-off-by: Mattias Andrée <maandree@kth.se>
Diffstat (limited to 'xcftools [moved to community]')
-rw-r--r--xcftools [moved to community]/.gitignore1
-rw-r--r--xcftools [moved to community]/PKGBUILD30
l---------xcftools [moved to community]/upload1
-rwxr-xr-xxcftools [moved to community]/watch-20
-rw-r--r--xcftools [moved to community]/xcftools.patch27
5 files changed, 79 insertions, 0 deletions
diff --git a/xcftools [moved to community]/.gitignore b/xcftools [moved to community]/.gitignore
new file mode 100644
index 0000000..ff3de76
--- /dev/null
+++ b/xcftools [moved to community]/.gitignore
@@ -0,0 +1 @@
+versions
diff --git a/xcftools [moved to community]/PKGBUILD b/xcftools [moved to community]/PKGBUILD
new file mode 100644
index 0000000..a31dfbb
--- /dev/null
+++ b/xcftools [moved to community]/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
+# Previous maintainer: Jonathan Frawley <jonathanfrawley@gmail.com>
+
+pkgname=xcftools
+pkgver=1.0.7
+pkgrel=3
+pkgdesc="Miscellaneous command line tools for use with the open XCF format used by The GIMP"
+url="http://henning.makholm.net/software"
+arch=('x86_64' 'i686')
+license=('GPL2' 'perl')
+depends=('libpng' 'perl')
+optdepends=('gimp')
+makedepends=('libpng')
+source=("http://henning.makholm.net/xcftools/xcftools-${pkgver}.tar.gz"
+ "xcftools.patch")
+md5sums=('fd960b6470fb23520fc4b1ade6cf6e25'
+ '7439f6a8369a12913243ded6c93d31e1')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -i ../xcftools.patch
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}
+
diff --git a/xcftools [moved to community]/upload b/xcftools [moved to community]/upload
new file mode 120000
index 0000000..1e7a8be
--- /dev/null
+++ b/xcftools [moved to community]/upload
@@ -0,0 +1 @@
+../upload \ No newline at end of file
diff --git a/xcftools [moved to community]/watch- b/xcftools [moved to community]/watch-
new file mode 100755
index 0000000..09ac1eb
--- /dev/null
+++ b/xcftools [moved to community]/watch-
@@ -0,0 +1,20 @@
+#!/bin/sh
+
+[ -f 'versions' ] && rm 'versions'
+wget http://henning.makholm.net/xcftools -O - | grep -Po '<a [^>]*>' | grep 'xcftools' | grep -v asc > versions
+if [ $? = 0 ]; then
+ [ -f unfetchable ] && rm unfetchable
+ md5sum < versions > new-sum
+ touch sum
+ if [ "$(cat sum)" = "$(cat new-sum)" ]; then
+ rm new-sum
+ else
+ mv new-sum sum
+ echo 'xcftools'
+ fi
+ rm versions
+elif [ ! -f unfetchable ]; then
+ touch unfetchable
+ echo 'xcftools (unfetchable)'
+fi
+
diff --git a/xcftools [moved to community]/xcftools.patch b/xcftools [moved to community]/xcftools.patch
new file mode 100644
index 0000000..1a2d88c
--- /dev/null
+++ b/xcftools [moved to community]/xcftools.patch
@@ -0,0 +1,27 @@
+diff -rupN xcftools-1.0.7.old/Makefile.in xcftools-1.0.7/Makefile.in
+--- xcftools-1.0.7.old/Makefile.in 2009-07-03 11:31:56.000000000 +0100
++++ xcftools-1.0.7/Makefile.in 2012-01-03 13:03:51.152358830 +0000
+@@ -79,7 +79,7 @@ xcf2pnm$e: xcf2pnm.$o $(FILEIO).$o enums
+
+ xcf2png$e: xcf2png.$o $(FILEIO).$o enums.$o xcf-general.$o utils.$o nlsini.$o \
+ pixels.$o flatten.$o flatspec.$o scaletab.$o table.$o palette.$o
+- $(CC) $(LDFLAGS) $(LIBS) -lpng $^ -o $@
++ $(CC) $(LDFLAGS) $(LIBS) $^ -lpng -o $@
+
+ xcfview: xcfview.in Makefile
+ sed '1s,/usr/bin/perl,@PERL@,' < $< > $@
+diff -rupN xcftools-1.0.7.old/xcf2png.c xcftools-1.0.7/xcf2png.c
+--- xcftools-1.0.7.old/xcf2png.c 2009-07-03 11:31:52.000000000 +0100
++++ xcftools-1.0.7/xcf2png.c 2012-01-03 13:03:36.262509165 +0000
+@@ -71,9 +71,9 @@ init_output(void)
+
+ outfile = openout(flatspec.output_filename);
+ libpng = png_create_write_struct(PNG_LIBPNG_VER_STRING,
+- png_voidp_NULL,
++ (png_voidp)NULL,
+ my_error_callback,
+- png_error_ptr_NULL);
++ (png_voidp)NULL);
+ if( !libpng )
+ FatalUnexpected(_("Couldn't initialize libpng library"));
+